Примеры операций с функциями. Автосуммирование с несколькими условиями


Примеры операций с функциями. Автосуммирование с несколькими условиями



В данном примере необходимо использовать формулу массива, а также две функции CУММ и ЕСЛИ.

Для примера рассмотрим следующую таблицу данных:
Цель – необходимо подсчитать остаток чая, цена закупки которого 21 руб.

  • В окне открытого листа выделите ячейку, где будет результат сложения с условием.
  • Введите знак равно (=) и наберите имя функции СУММ.
  • Откройте круглые скобки и наберите имя функции ЕСЛИ.
  • Откройте две круглые скобки подряд.
  • Введите адреса диапазон ячеек для первого условия. В нашем примере это диапазон «А2:А8».
  • Введите знак равно (=) и наберите в кавычках имя первого критерия отбора и закройте круглую скобку. В нашем примере это текстовое значение «Чай».
  • Введите знак умножения (*) и откройте следующую круглую скобку.
  • Введите адреса диапазон ячеек для второго условия. В нашем примере это диапазон D2:D8.
  • Введите знак равно (=) и наберите второй критерий отбора, а затем закройте круглую скобку. В нашем примере это числовое значение 21.
  • Введите знак перечисления диапазонов (;).
  • Введите адреса диапазон ячеек для выборки значений и закройте две круглые скобки подряд. В нашем примере это диапазон ячеек С2:С8.
  • Используйте сочетание клавиши для создания формулы массива Ctrl+Shift+Enter.
  • Созданная формула примет вид {=СУММ(ЕСЛИ((А2:А8=«Чай»)*(D2:D8=21);С2:С8))}. Результатом вычисления станет 15.
23.07.20114703

»Excel 2007 » Работа с функциями » Примеры операций с функциями. Автосуммирование с несколькими условиями




Читайте ранее:
Примеры операций с функциями. Автосуммирование с одним условием

В данном случае для сложения значений одного диапазона, учитывая данные другого диапазона ячеек, необходимо использовать функцию СУММЕСЛИ.

Закрыть