Когда в Excel применяется «Подбор параметра»


Когда в Excel применяется «Подбор параметра»



Как вы могли понять из предыдущего примера о преобразовании милей в километры, средство Подбор параметра применяется тогда, когда вы знаете значение, которое должна возвращать формула, но не знаете входное значение для формулы, обеспечивающее желаемый результат вычислений.

Другими словами, это средство применяется в случае, если на рабочем листе имеется одна ячейка с числовым значением, а другая — с формулой, зависящей от значения в первой ячейке, и необходимо подобрать такое значение в первой ячейке, чтобы в ячейке с формулой получилось заданное вами значение. Например, на рабочем листе, показанном на рис. 1.2, в ячейке А1 записана оптовая цена некоторого товара (595 руб.), а в ячейке А2 записана формула =ОКРУГЛ(A1+(A1*8,8%);2), которая вычисляет розничную цену этого же товара, увеличивая его оптовую цену на 8,8%. Теперь необходимо узнать, какова оптовая цена другого товара, если его розничная цена равна 1099 руб. Подбор параметра быстро определит, что в этом случае оптовая цена составляет 1010 руб.

Рис. 1.2. Подбор параметра для определения оптовой цены

Рис. 1.2. Подбор параметра для определения оптовой цены

В другом примере, показанном на рис. 1.3, в ячейке А1 содержится число 1000, в данном случае это 1000 чайных ложек (есть такая мера измерения объемов жидкостей). В ячейке А2 с помощью формулы =ПРЕОБР(A1;"tsp";"cup") 1000 чайных ложек пересчитывается на количество чашек (есть и такая мера измерения объемов жидкостей), а в ячейке A3 посредством формулы =ПРЕОБР(A2;"cup";"l") это количество чашек пересчитывается в литры. (По этим формулам будут получены числа 20,83… и 4,929… в ячейках А2 и A3 соответственно.)

Рис. 1.3. Подбор параметра для преобразования чайных ложек в литры

Рис. 1.3. Подбор параметра для преобразования чайных ложек в литры

Если же вы хотите знать, сколько чайных ложек содержится в одном литре, то можно воспользоваться средством Подбор параметра, которое сразу даст искомое число 202,84 (чайных ложек).

11.09.20132080

»Excel 2007 » Сценарии и подбор параметра » Когда в Excel применяется «Подбор параметра»




Читайте ранее:
Назначение средства «Подбор параметра» в Excel

Средство Подбор параметра находит такое значение параметра (это значение будет записано в указанной ячейке рабочего листа), которое обеспечит требуемое значение,...

Закрыть