Как создать формулу массива с несколькими ячейками?


Как создать формулу массива с несколькими ячейками?



Рассмотрим создание формулы массива с несколькими ячейками на следующем примере.

Имеются следующие диапазоны данных – А2:А6 и В2:В6.
Необходимо умножить значения диапазона А2:А6 на значения В2:В6.

  • В окне открытого листа выделите диапазон ячеек, где будет располагаться формула массива и введите знак ( = ). В нашем примере пусть это будут ячейки С2:С6.
  • Введите первый нужный диапазон ячеек А2:А6.
  • Введите оператор умножения ( * ), а затем следующий диапазон ячеек В2:В6.
  • Завершите операцию сочетанием клавиш Ctrl+Shift+Enter.
  • Созданная формула примет вид {=А2:А6*В3:В6}.
Примечание
В каждой ячейке выделенного диапазона будет находиться свой экземпляр формулы, которую нельзя удалить отдельно клавишей Delete.

Как создать формулу массива с одной ячейкой?

Имеется следующие диапазоны данных – А2:А6, В2:В6, D2:D6 и Е2:Е6. Необходимо умножить значения диапазона А2:А6 на значения В2:В6, затем значения диапазона D2:D6 на значения Е2:Е6.
Полученные результаты следует сложить.

  • В окне открытого листа выделите ячейку, где будет располагаться формула массива и введите знак ( = ). Пусть в нашем примере это будет ячейка F2.
  • Введите название функции автосуммирования СУММ.
  • Откройте круглые скобки и введите первый нужный диапазон ячеек А2:А6.
  • Введите оператор умножения ( * ), а затем следующий диапазон ячеек В2:В6.
  • Введите оператор перечисления (;), а затем следующий диапазон ячеек D2:D6.
  • Введите оператор умножения ( * ), а затем последний диапазон ячеек Е2:Е6
  • Закройте круглые скобки и нажмите сочетание клавиш Ctrl+Shift+Enter.
  • Созданная формула преобразится и примет вид {=СУММ(А2:А6*В3:В6;D2:D6*E2:E6)}.
19.07.20113811

»Excel 2007 » Работа с формулами » Как создать формулу массива с несколькими ячейками?




Читайте ранее:
Массив. Формулы массива в книгах Excel

Массив – это несколько наборов значений, объединенных общими вычислениями.

Закрыть