Трюк №68. Как применить подсчет данных только по одному вхождению каждой записи в списке Excel 2010

Если у вас есть большой список элементов, вы, возможно, захотите подсчитать элементы без учета их повторных вхождений в список. При помощи этого трюка вы сможете сосчитать каждую запись только один раз.

Предположим, есть список, отсортированный, чтобы было проще заметить повторяющиеся записи.

Рис. 6.10. Диапазон отсортированных имен

Рис. 6.10. Диапазон отсортированных имен

Если подсчитать элементы этого списка обычным образом, используя функцию СЧЁТЗ (COUNTA), получится по несколько вхождений имен Bill W, Dave H, Frank Т, Frank W и Mary О. Функция БСЧЁТА (DCOUNTA) предлагает альтернативный вариант, очень эффективный и легко настраиваемый.

Синтаксис функции БСЧЁТА (DCOUNTA) — DCOUNTA(database;field;criteria), в русской версии Excel БСЧЁТА(база_данных;поле;критерий).

У этой функции те же аргументы, что и у функции БДСУММ (DSUM), описанной в разделе «Трюк № 65. Преобразование дат в отформатированные даты Excel».

Создав предыдущий список, в ячейке D1 введите слово Criteria (или любой другой заголовок, не совпадающий с заголовком поля или столбца). Под ним, в ячейке D2, введите формулу =COUNTIF($A$2:A2;A2)=1, в русской версии Excel =СЧЁТЕСЛИ($А$2:А2;А2)=1. Обратите внимание на комбинацию относительных (А2) и абсолютных ($А$2) ссылок! Это необходимо для того, чтобы критерий правильно работал.

Теперь в ячейке, где должен оказаться результат, введите следующую функцию: =DCOUNTA($A$1:$А$100;1;$D$1:$D$2), в русской версии Excel =БСЧЁТА($А$1:$А$100;1;$D$1:$D$2). Она будет применять критерий для исключения дубликатов и выдаст вам необходимый результат, равный 11, так как в списке 11 уникальных имен.

Top