Трюк №39. Что такое адресация данных по имени в ячейках таблиц Excel?


Трюк №39. Что такое адресация данных по имени в ячейках таблиц Excel?



Вероятно, самое большое преимущество использования именованных диапазонов заключается в том, что формулы становится намного проще читать и понимать, причем не только вам, но и другим пользователям, которым приходится работать с вашими электронными таблицами.

Используя именованные диапазоны (несомненно, одну из самых полезных возможностей Excel), можно сослаться на диапазон ячеек и назначить ему определенное имя. После этого можно ссылаться на этот диапазон по имени, а не по адресу. Хотя именованные диапазоны и представляют собой мощный инструмент,

Хотя номера ячеек лежат в основе всего, что делает Excel, намного проще запоминать имена, например, Item Number или Quantity, чем номера ячеек, например, А1:А100, В Excel это сделать просто.

В Excel используется одна и та же техника определения именованных ячеек и именованных диапазонов — поле имени в левой части строки формул. Чтобы присвоить имя ячейке, выделите ее, введите нужное имя в поле имени (рис. 3.1) и нажмите клавишу Enter. Чтобы присвоить имя диапазону ячеек, выделите диапазон, введите нужное имя для диапазона в поле имени и нажмите клавишу Enter.

Рис. 3.1. Присваивание ячейке имени MyFavoriteCell

Рис. 3.1. Присваивание ячейке имени MyFavoriteCell

Раскрывающийся список справа в поле имени позволяет находить именованные диапазоны и ячейки (дополнительные способы поиска диапазонов вы найдете в статье «Трюк № 44. Поиск именованных диапазонов на рабочем листе»). Если точно выделить диапазон, вместо обычных ссылок на ячейки в поле имени появится его имя. В формулах эти имена можно применять вместо идентификаторов ячеек или диапазонов. Если вы назовете ячейку Е4 «date», то сможете использовать формулу =date вместо =Е4. Схожим образом если вы создадите диапазон с названием «quantity» в ячейках АЗ:А10, то сможете написать формулу =CУMM(quantity) (=SUM(quantity)) вместо =СУММ(АЗ:А10) (=SUM(A3:A10)).

По мере того как электронные таблицы становятся больше и сложнее, именованные ячейки и диапазоны становятся жизненно необходимым инструментом для поддержания понятности и управляемости таблиц.

30.09.20124316

»Трюки с именованием » Трюк №39. Что такое адресация данных по имени в ячейках таблиц Excel?




Читайте ранее:
Как, зная IP-адрес, узнать ваше географическое местоположение?

Ваш IP-адрес посылается каждому посещаемому вами веб-сайту. Хотя определить ваш точный домашний адрес и размер обуви непосредственно по IP-адресу невозможно,...

Закрыть